Resolved
Amazon Web Services is experiencing problems, affecting our backend server

Started
July 13, 2021 at 12:29 PM
Status
Resolved after 41 minutes

Impact

Minor outage
Affected
Application
  • Resolved

    We just resolved the issue!

  • Identified

    We are continuing to work on a fix for this incident.