Resolved
Website and Webapp not loading for some customers

Started
June 08, 2021 at 10:14 AM
Status
Resolved after 41 minutes

Impact

Partial outage
Affected
Application
Website
  • Resolved

    The issue has been resolved by Google Cloud

  • Identified

    This is an issue with Google Cloud affecting multiple websites world-wide. They are working on resolving the issue.